Tipe LSA OSPF

Ospf menggunakan Link State Database (LSDB) dan mengisi database ini dengan LSA (Link State Advertisement). Pada artikel ini, telah disebutkan tipe tipe LSA. Dari pada menggunakan 1 LSA, ospf akan menggunakan berbagai macam tipe LSA. Tipe - tipe LSA ini adalah 
    • LSA tipe 1  : Router LSA
    • LSA tipe 2  : Network LSA
    • LSA tipe 3  : Summary LSA
    • LSA tipe 4  : Summary ASBR LSA
    • LSA tipe 5  : AS external link LSA  
    • LSA tipe 6  : Multicast LSA (tidak didukung router cisco)
    • LSA tipe 7  : NSSA LSA

LSA Tipe 1

Ok kita akan lihat LSA tipe 1 ini, menggunakan topologi di bawah ini.
ospf topologi











Konfigurasikan ospf pada kedua router diatas, caranya dapat dilihat disini. Sekarang kita akan lihat database pada router R2 menggunakan perintah show "ip ospf database".
sh ip ospf database
Dari hasil perintah "show ip ospf database" terlihat 2 buah lsa yang di-generate oleh router R2 dengan link id 12.12.12.2) dan router R1 dengan link ID 12.12.12.1. LSA ini selalu berada dalam satu area, dan tidak akan berpindah ke area lain.

LSA Tipe 3

Dengan topologi yang sama, kita akan menambahkan satu area lagi, sehingga topologinya akan seperti dibawah ini.

Sekarang Router R1 akan berfungsi sebagai router ABR. Router R1 akan membuat LSA tipe 3 dan membanjiri area 0 dan area lain dengan LSA tipe 3, dan dengan cara ini router pada satu area tahu tentang network pada area lain.
Jika kita lihat pada tabel routing router R2, akan muncul rute dengan kode "O IA". Inilah LSA tipe 3 Summary.
Show ip route ospf










LSA Tipe 2

Masih ingat tipe network ospf ? LSA tipe 2 atau network LSA digunakan pada network multiaccess. Pada tipe network multiacces, ospf akan mengadakan pemilihan DR/BDR.
Kita akan lihat tipe LSA tipe 2 ini dengan topologi seperti dibawah ini,

ospf topologi










Pada area 20, kita menggunakan switch untuk menghubungkan router R2, router R4 dan router R5. Kita lihat database ospf di router R4 menggunakan perintah "show ip ospf database". Seperti LSA tipe 1, LSA tipe 2 ini hanya akan beada dlam satu area.
show ip ospf database
 

LSA tipe 4 dan LSA tipe 5

Sejauh ini kita telah melihat LSA tipe 1, 2 dan 3. Untuk melihat LSA tipe 4 dan tipe 5 kita membutuhkan ASBR. Masih ingat ASBR ? Untuk membuat ASBR, saya akan redistribute network lain pada router R4 

R4#
R4# configure terminal
R4(config)# interface loopback 0
R4(config-if)# ip address 44.44.44.44 255.255.255.0
R4(config-if)# router ospf 20
R4(config-router)# redistribute connected subnets
R4(config-router)# ^Z
Menggunakan topologi yang sama diatas, saya membuat interface loopback 0, memberikan ip address, dan memberitahukan ospf untuk redistribute interface loopback ini pada ospf. Mari kita lihat database ospf (LDSB) pada router R3 dan router R1.
show ip ospf database router cisco






















Router R3 berada dalama area lain dari router R4, sehingga router R3 ini perlu tahu dimana ASBR. Pada LSDB router R3 kita dapat melihat tipe 5 external LSA dan tipe 4 summary ASBR yang berisi ip address router R4. Karena LSA tipe 4 inilah router R3 tahu bagaimana mencapai ASBR. LSA ini dibuat oleh router R1. 

LSA tipe 7 

LSA tipe ini akan selalu berada dalam area (area nssa). Router ospf diluar area nssa akan melihat sebaga tipe 5 LSA.
Menggunakan topologi yang sama, saya akan mengubah area 30 menjadi nssa (not-so-stubby area)

R3(config)# router ospf 30R3(config-router)# area 30 nssa
R3(config-router)# ^Z

R1(config)# router ospf 1
R1(config-router)# area 30 nssa
R1(config-router)# ^Z

Ok sekarang area 30 adalah area nssa, saya akan membuat interface loopback dan me-redistribute pada ospf.

R3(config)# interface loopback 0
R3(config-if)# ip address 33.33.33.33 255.255.255.0
R3(config-if)# router ospf 30
R3(config-router)# redistribute connected subnets
R3(config-router)# ^Z

Ok sekarang kita lihat LSDB router R1 dan router R3,
sh ip ospf database lsa tipe 7 R1
show ip ospf database lsa type 7 router R3

Router R1 mempunyai LSA tipe 7 ini, karena router ini berada dalam satu area dengan router R1. Router R1 akan men- translate LSA tipe 7 menjadi LSA tipe 5 external dan membanjiri area 0, karena router ini adalah router ABR.
ttranslation type 7 to type 5 lsa

Sekarang kita akan melihat LDSB pada router R4 yang berada pada area lain,
show ip ospf database router cisco

Router R4 hanya mempunyai LSA tipe 5, yang membuktikan bahwa LSA tipe 7 hanya berada pada area nssa.  

Download file konfigurasi lab ini.

No comments :