OSPF Summarization

Tidak seperti EIGRP atau RIP yang melakukan summarization secara otomatis, OSPF tidak mempunyai fitur ini. Pada dasarnya summarization adalah  meringkas subnet - subnet network untuk kemudahan manajemen atau troubleshooting dan menghemat resource router.

Pada routing protokol OSPF, summarization tidak mungkin dilakukan pada sebuah area. Kita melakukan summarization pada router ABR dan ASBR, dan dilakukan secara manual, dan OSPF hanya dapat melakukan summarization pada LSA tipe 3 dan LSA tipe 5. 
Pada lab ini, kita akan belajar cara konfigurasi summarization pada routing protokol OSPF, menggunakan topologi dibawah ini.
Ospf Summarizaton topology

Perhatikan topologi diatas, jika kita tidak melakukan summarization, router R1 akan meng- generate LSA tipe 3 untuk setiap network dan akan disebarkan pada area 15. Begitu juga dengan router R3. Jika salah satu link gagal pada area 15, router R2 akan membanjiri area 0 dengan LSA tipe 3 yang terbaru, akibatnya LSDB akan berubah. Perubahan LSDB akan membuat ospf menjalankan lagi algoritma SPF yang memakan waktu dan resource router, dan perubahan topologi ini harus diumumkan pada semua area ospf. 
Seperti terlihat pada gambar dibawah ini.

show ip ospf database
Jika kita melakukan summarization, akan berbeda hasilnya. Jika link ke network 172.16.1.0 failure pada area 15, tidak ada yang berubah pada area 0 ataupun area 10, karena area - area tersebut tidak mempunyai LSA tipe 3 yang spesifik (menunjuk ke network 172.16.1.0), pada LSDB-nya tetapi LSA yang menunjuk pada network summary.

Ok, sekarang kita konfigurasikan summarization pada router R2, karena router ini adalah ABR.


R2# configure terminal
R2(config)# router ospf 1
R2(config-router)# area 15 range 172.16.0.0 255.255.0.0

Dengan menggunakan perintah area area-id range summary-address, saya membuat summary 172.16.0.0 /16, untuk network untuk 172.16.0.0 - 172.16.4.0.
 
KIta lihat ospf database pada router R4
show ip ospf database summarization

Bagaimana dengan tabel routing pada router R4 ?
show ip route after summary

File gns3 lab ini dapat didownload disini.

Virtual Link OSPF

Ospf didesain menggunakan area. Area backbone ini harus contiguous dan area - area nonbackbone harus tersambung pada area backbone melalui ABR.  Pada beberapa kasus, terkadang kita harus menambahkan area baru atau memperluas area backbone. Dan pada kasus - kasus tersebut solusinya sederhana, desain ulang area. 

Jika solusi itu menyita waktu dan tenaga, Ospf menyediakan cara alternatif, virtual link. 

OSPF Virtual Link  

 

ospf topologi need virtual link

Perhatikan contoh topologi jaringan OSPF diatas. Secara desain, topologi diatas tidak memenuhi syarat ospf. Pada contoh 1 kita mempunyai masalah area 20 tidak terkoneksi langsung pada area 0, sedangkan pada contoh 2, masalahnya adalah discontiguous area 0. Normalnya, topologi diatas tidak akan bekerja, tetapi kita dapat membuatnya bekerja menggunakan virtual link. 
Pada "dasarnya" virtual  link akan membuat "tunnel" sehingga area 20 seolah "directly connected" pada area 0 (contoh 1), atau area 0 saling tersambung (contoh 2). 

ospf virtual link

 

Konfigurasi Ospf Virtual Link

Kita akan menggunakan topologi dibawah ini, untuk konfigurasi virtual link.
topology ospf virtual link

Router R2
R2# configure terminal
R2(config)# router ospf 1
R2(config-router)# router-id 2.2.2.2
R2(config-router)# area 10 virtual-link 3.3.3.3
R2(config-router)# 

Router R3
R3# configure terminal
R3(config)# router ospf 1
R3(config-router)# router-id 3.3.3.3
R3(config-router)# area 10 virtual-link 2.2.2.2
R3(config-router)# 

Konfigurasi virtual link dilakukan pada ABR, dan menggunakan perintah area area-id virtual-link router-id
Area-id adalah area dimana kita membutuhkan virtual link (area 10). Router-id* adalah router-id ABR lainnya.

Perhatikan konfigurasi Router R2, perintah router-id 2.2.2.2. Ini adalah perintah yang membuat router R2 ini mempunyai router-id 2.2.2.2, bukan ip address dari router R2. Perintah area 10 virtual-link 3.3.3.3 membuat virtual link dari router R2 ke router R3 (router-id.3.3.3.3) melewati area 10.

Verifikasi

Untuk melihat apakah virtual link sudah bekerja, kita gunakan perintah show ip ospf virtual-links.
show ip ospf virtual link

Kita lihat LSDB router R2, virtual link muncul sebagai tipe 1 LSA , router LSA. Kita juga dapat melihat code DNA yang berarti Do Not Age.

show ip ospf database

 
Download file gns3 lab virtual link disini.

 * Penjelasan Router ID dapat dilihat disini.

Konfigurasi OSPF Authentication

Routing protokol dapat di proteksi dengan menggunakan password, tidak terkecuali OSPF. Jika OSPF di konfigurasi menggunakan authentication, OSPF akan mengecek setiap paket OSPF yang diterima. Jika pada EIGRP, authentication dilakukan dengan menggunakan keychain, pada OSPF authentication lebih mudah untuk dikonfigurasikan.

Seperti EIGRP, ada 3 tipe authentication yang didukung oleh ospf :
  • Null - Tipe 0 atau tanpa authentication
  • Plaintext - Tipe 1 tanpa enkripsi
  • MD5 authentication - Tipe 2 menggunakan enkripsi MD5

Langkah - langkah konfigurasi authentication OSPF

Untuk mengaktifkan authentication pada OSPF
  1. Pada menu konfigurasi interface kita men-setting passwordnya
  2. Kemudian mengaktifkan authentication melalui menu konfigurasi router.
OK, langsung ke lab, kita akan mengunakan topologi dibawah ini untuk referensi
OSPF Authentication Topology

Pada Area 20 terdapat network 1.1.1.0/24 yang terhubung pada router R1, dan pada area 10 terdapat network 3.3.3.0/24 yang terhubung pada router R2. Untuk cara konfigurasi ospf pada router cisco dapat dilihat disini

Plaintext

Router R1
R1# configure terminal
R1(config)# interface fa0/0
R1(config-if)# ip ospf authentication
R1(config-if)# ip ospf authentication-key 123456

Router R2
R2# configure terminal
R2(config)# interface fa0/0
R2(config-if)# ip ospf authentication
R2(config-if)# ip ospf authentication-key 123456


Dengan menggunakan perintah ip ospf authentication, kita mengaktifkan authentication plaintext pada level interface. Disini saya men-setting passwordnya 123456 menggunakan perintah ip ospf authentication-key.

Jika kita mempunyai banyak interface, mungkin kita tidak ingin mengkonfigurasi setiap interface, tetapi dapat menggunakan perintah area area-id authentication, seperti dibawah ini

Router R1
R1(config)# router ospf 1
R1(config-router)# area 0 authentication

Router R2
R2(config)# router ospf 1
R2(config-router)# area 0 authentication

Perintah diatas akan mengaktifkan authentication pada area 0. 

Verifikasi

Untuk melihat apakah authentication sudah aktif atau tidak, kita gunakan perintah show ip ospf dan debug ip ospf packet.

show ip ospf
debug ip ospf packet


Enkripsi MD5

MD5 authentication diaktifkan dengan perintah yang berbeda dari plaintext diatas. Pertama kita menggunakan perintah ip ospf message-digest-key no-key md5 password untuk membuat key dan passwordnya, dan kemudian untuk mengaktifkannya mengunakan perintah ip ospf authentication message-digest. Perhatikan bahwa nomor key boleh bebas, tetapi harus sama pada kedua router. Perintah - perintah ini dikonfigurasi melalui menu konfigurasi interface.

Router 1
R1(config)# interface fa0/0
R1(config-if)# ip ospf message-digest-key 1 md5 123456
R1(config-if)# ip ospf authentication message-digest

Router2
R2(config)# interface fa0/0
R2(config-if)# ip ospf message-digest-key 1 md5 123456
R2(config-if)# ip ospf authentication message-digest

Pada perintah di atas, saya membuat key dengan nomor key 1 dan passwordnya 123456. Untuk mengaktifkan per-area, gunakan perintah area area-id authentication message-digest.  


Router R1
R1(config)# router ospf 1
R1(config-router)# area 0 authentication message-digest

Router R2
R2(config)# router ospf 1
R2(config-router)# area 0 authentication message-digest


Verifikasi
show ip ospf authentication
debug ip ospf packet authentication

Bagaimana jika router R1 menggunakan md5 authentication sedangkan router R2 menggunakan plaintext? Gunakan saja perintah debug ip ospf adj, 
debug ip ospf adj mismatch authentication type

Download lab gns3 disini.

Konfigurasi Totally NSSA OSPF

Area Totally NSSA adalah Area istimewa pada OSPF. Perbedaan dengan area NSSA  adalah , pada area NSSA, LSA tipe 5 diblok tetapi tipe tiga dan tipe 4 diijinkan sedangkan pada totally nssa, LSA tipe 3, 4 dan 5 semuanya diblok.
Tujuan designer OSPF membuat berbagai macam area ini adalah untuk memperkecil LSDB sehingga perhitungan SPF lebih cepat. Akibatnya waktu convergence yang cepat.

Pada latihan ini, kita akan mengkonfigurasikan area totally NSSA OSPF, menggunakan topologi berikut,
totally nssa ospf topology
Pada topologi diatas, terdapat 3 area, area 10, area 0 dan area 20.
Area 0 seperti biasa adalah area backbone atau area transit. Area 20 adalah area standar OSPF. Pada router R5 area 20, saya membuat dua buah network (diwakilkan oleh interface loopback). Network pertama dengan ip address 5.5.1.1/24 akan termasuk dalam ospf area 20, sedangkan network kedua dengan ip address 5.5.2.1/24 akan saya distribusikan pada OSPF.
Pada area 10 akan di distribusikan routing protokol RIP melalui router R2. 
Area 10 akan di jadikan Notally NSSA.
Cara konfigurasi dasar OSPF dapat dilihat disini.

OK sekarang saya akan konfigurasikan router R5, dan memasukkan network 5.5.2.0/24 pada ospf menggunakan perintah "redistribute".

R5# configure terminal
R5(config)# interface loopback 0
R5(config-if)# ip address 5.5.1.1 255.255.255.0
R5(config-if)# interface loopback 1
R5(config-if)# ip address 5.5.2.1 255.255.255.0
R5(config-if)# router ospf 20
R5(config-router)# network 5.5.1.0 0.0.0.255 area 20
R5(config-router)# redistribute connected subnets
R5(config-router)# ^Z

Setelah meng-konfigurasikan router R5, sekarang saya akan meng-konfigurasikan area 10 sebagai Totally NSSA.

Router R1
R1# configure terminal
R1(config)# router ospf 10
R1(config-router)# area 10 nssa
R1(config-router)# ^Z

Router R2
R2# configure terminal
R2(config)# router ospf 10
R2(config-router)# area 10 nssa no-summary
R2(config-router)# ^Z

Router R3
R3# configure terminal
R3(config)# router ospf 1
R3(config-router)# area 10 nssa no-summary
R3(config-router)# ^Z

Perhatikan konfigurasi pada router R3. Router R3 adalah router ABR yang menghubungkan area 0 dan area 10. Untuk konfigurasi totally nssa pada router ABR kita menggunakan perintah "area area-id nssa no-summary". Perintah ini memastikan tidak ada LSA tipe 3 yang memasuki area Totally NSSA, dengan kata lain LSA tipe 3 akan diblok pada router ABR, dan router ABR akan membuat LSA tipe 3 dengan link ID 0.0.0.0 yang akan disebarkan pada area Totally NSSA.

Sekarang kita akan konfigurasikan RIP pada router R6 dan router R2. Untuk konfigurasi router RIP dapat dilihat disini. Pada router R2 saya akan redistribute RIP ke dalam OSPF dan begitu juga sebaliknya.

Router R2
R2# configure terminal
R2(config)# router rip 
R2(config-router)# version 2
R2(config-router)# no auto-summary
R2(config-router)# network 16.16.16.0 
R2(config-router)# redistribute ospf 10 metric 5
R2(config-router)# router ospf 10
R2(config-router)# redistribute rip metric 10 subnets
R2(config-router)# ^Z

Ok sekarang kita lihat LSDB pada router R1, 
show ip ospf database

Bagaimana dengan tabel routingnya ?
tabel routing totally nssa  

Download file lab gns3 ini.