OSPF Single Area

Pada artikel ini, kita telah berkenalan sedikit dengan ospf, tipe area pada ospf, tipe Link State Advertisement (LSA) dan cara kerja ospf. 

Menggunakan topologi berikut, kita akan belajar cara konfigurasi dasar ospf 
topologi ospf configuration

Konfigurasi OSPF 

Perhatikan pada topologi di atas, router R1 dihubungkan dengan interface serial pada router R2. Router R3 di hubungkan dengan interface fast ethernet dengan router R2. Ketiga router berada dalam satu area, area 0 atau area backbone.  
Network 172.16.0.0/24 adalah LAN pada router R1 L
Ok kita konfigurasikan ospf pada ketiga router. 


Router R1
R1# configure terminal
R1(config)# router ospf 1
R1(config-router)# network 12.12.12.0 0.0.0.3 area 0
R1(config-router)# network 172.16.0.0 0.0.0.255 area 0
R1(config-router)# network 200.0.0.1 0.0.0.0 area 0
R1(config-router)# exit

Router R2
R2# configure terminal
R2(config)#router ospf 100
R2(config-router)# network 0.0.0.0 255.255.255.255 area 0
R2(config-router)# exit
R2(config)#

Router R3
R3# configure terminal
R3(config)# interface fastEthernet 0/0
R3(config-if)# ip ospf 1 area 0 
R3(config-if)# interface loopback 0
R3(config-if)# ip ospf 1 area 0
R3(config-if)# interface loopback 1
R3(config-if)# ip ospf 1 area 0
R3(config-if)# exit
R3(config)# router ospf 1
R3(config-router)# router-id 10.10.10.10 

Cara konfigurasi pada router R1 adalah yang paling umum, dimana kita mengaktifkan routing protokol ospf pada router cisco, meng-advertise network dan menentukan area. Pada router R2 adalah versi singkatnya, daripada menggunakan ip address network yang akan diadvertise, kita gunakan wildcard -nya, sehingga perintah "network 0.0.0.0 255.255.255.255 area 0" berarti semua ip address pada interface aktif (up/up) akan dimasukkan dalam area 0.

Pada router R3, kita mengkonfigurasikan ospf langsung dibawah interface, sintaks-nya adalah ip ospf ospf-process area-ospf.  

Rentang nilai proses ospf ini adalah 1 - 65535, dan tidak perlu sama untuk setiap router.

Router ID 

Setiap proses ospf membutuhkan Router ID (RID). Router ID ini di gunakan untuk membangun database-nya. RID ini ditentukan dari 
  1. perintah router-id, (pada router R3)
  2. Ip Address tertinggi interface loopback, (pada router R1)
  3. Ip Address tertinggi interface aktif. (pada router R2)
router ID


Verifikasi Ospf

Untuk verifikasi ospf, kita dapat menggunakan perintah berikut 

show ip protocols
show ip protocols
 
show ip ospf interface brief
show ip ospf interface brief

show ip ospf neighbors
show ip ospf neighbor

show ip ospf database 
Ini adalah topologi lengkap jaringan ospf. Dalam satu area, database ini sama. 
show ip ospf database R2
database router R2
show ip ospf database R1
database router R1
show ip route
show ip route

Download file konfigurasi "ospf single area" ini disini.

No comments :